51dev.com IT技术开发者社区

51dev.com 技术开发者社区

安装

Vue(3)- 安装脚手架、过滤器、生命周期的钩子函数、vue-router基本使用

Vue(3)- 安装脚手架、过滤器、生命周期的钩子函数、vue-router基本使用

一、安装脚手架1、下载node.js,本文下载版本为node-v8.12.0-x64.msi,一键式安装。2、安装完成后,打开终端,输入node,可进入node环境(两次ctrl+c退出),如下图:3、查看版本,如下图:4、在成功安装node.js(即能够成功查看版本如上图)的前提下,再安装淘宝npm(http://n...

MySQL数据库(1)- 数据库概述、MySQL的安装与配置、初始SQL语句、MySQL创建用户和授权

MySQL数据库(1)- 数据库概述、MySQL的安装与配置、初始SQL语句、MySQL创建用户和授权

一、数据库概述1、什么是数据(Data)      描述事物的符号记录称为数据,描述事物的符号既可以是数字,也可以是文字、图片,图像、声音、语言等,数据由多种表现形式,它们都可以经过数字化后存入计算机。     ...

安装Spring Tool Suite(STS)

安装Spring Tool Suite(STS)

JAVA开发工具中,常用工具就是Eclipse,IntelliJIDEA。现在使用springboot&cloud框架进行开发的时候,虽然可以使用上面两个工具,但都未必就真的量身定制,IntelliJ虽说是神器,但太重,而且是收费的,免费的社区版也是一个阉割版。Eclipse当然ok,但要装一些插件。Sprin...

debian8.5安装sublime text3

debian8.5安装sublime text3

在官网www.sublimetext.com下载安装包我这里用的是Ubuntu64bit版。下载后使用su命令切换到root账户。执行安装命令dpkg-isublime-text*.deb安装后执行命令:subl打开sublime。...

angular.js测试框架protracotr安装所需的node版本

angular.js测试框架protracotr安装所需的node版本

protractor内代码的语法是基于ES6的,比如:里面用到了展开运算符“...”,node.js6.0以下是不支持该语法特性。所以,安装protractor是不会报错,但运行webdriver-manager的升级就会报那三个点无法识别。 需要将node.js升级到6.0+就能解决该问题。 pr...

windows下通过Chocolatey安装或升级node.js

windows下通过Chocolatey安装或升级node.js

以管理员身份运行windowsPowerShell并安装Chocolatey我的机器是windows10,可以在开始菜单->所有应用->W栏中找到WindowPowerShell并运行。在命令行中运行命令:iwrhttps://chocolatey.org/install.ps1-UseBasicParsi...

编译安装vim8.0

编译安装vim8.0

由于我的网络问题,我downloadvim的原码进行手动编译:碰到的问题:1:编译的时候找不到python.h??   编译的vim的时候需要python支持,有两种一种python2,python3,若出现此错误都需要安装python2.7-dev或者python3.5-dev,然后重新...

Ubuntu12.04 Skype4.2 提示Skype can't connect,安装Skype4.3

Ubuntu12.04 Skype4.2 提示Skype can't connect,安装Skype4.3

最近几天Skype突然不能登录啦,以为是自己密码记错啦,重置啦一下密码,发现仍然提示”Skypecan'tconnect“,我的版本是Ubuntu12.04Skype4.2尝试啦很多办法仍然不能解决,后面在论坛上看到更新到Skype4.3可以解决这个问题,发现果然有效,下面是安装过程:Beforeweproceedwi...

arm汇编--ubuntu12.04 安装arm-linux交叉编译环境

arm汇编--ubuntu12.04 安装arm-linux交叉编译环境

1.安装标准的C开发环境,由于Ubuntu安装默认是不安装的,所以需要先安装一下:sudoapt-getinstallgccg++libgcc1libg++makegdb2.从ftp://ftp.arm.linux.org.uk/pub/armlinux/toolchain/下载最新版本的交叉编译器,我下载的是cros...

ubuntu14.04安装opencv3.0

ubuntu14.04安装opencv3.0

sudoapt-getupdatesudoapt-getupgrade搭建C/C++编译环境: sudoapt-getinstallbuild-essential安装关联库: sudoapt-getinstallcmakegitlibgtk2.0-devpkg-configlibavcodec-de...

ubuntu14.04安装ia32-lib

ubuntu14.04安装ia32-lib

sudoapt-getinstalllibc6:i386sudo-icd/etc/apt/sources.list.decho"debhttp://old-releases.ubuntu.com/ubuntu/raringmainrestricteduniversemultiverse">ia32-libs-ra...

ubuntu14.04安装百度云Bcloud

ubuntu14.04安装百度云Bcloud

git地址:https://github.com/LiuLang/bcloud-packages sudoapt-getinstallpython3-setuptoolsmd5sumbcloud_3.6.1-1_all.deb得到md5值,然后catchecksum.txt:692e17c5ca93f89bc...

ubuntu12.04下使用qemu模拟mips处理器安装debian

ubuntu12.04下使用qemu模拟mips处理器安装debian

注:ubuntu是不支持mips处理器的,只能在x86下安装运行第一步、安装qemu/sudoapt-getinstallqemuqemu-system。执行 qemu-system-mips--version发现版本太低,因为后面需要更高版本的qemu。下载http://wiki.qemu-project....

ubuntu adb devices 找不到任何东西,安装驱动

ubuntu adb devices 找不到任何东西,安装驱动

在Android平台下做开发,adb总是需要使用到的,同时,因为linux没有windows这样操作傻瓜化,有些东西还是需要自行设置的,否则将会连接不上。    关于这些内容,google也有一定的描述,可以参考http://developer.android.com/tools...

Elasticsearch安装部署总结

Elasticsearch安装部署总结

logstash是controller层,Elasticsearch是一个model层,kibana是view层Kibana依赖ElasticsearchLogstash数据输出到ElasticsearchElasticsearch数据来源依赖Logstash依赖顺序安装的服务:ElasticSearch->Lo...